ក្រុមការងារយើងខ្ញុំនិងខិតខំសិក្សារស្រាវជ្រាវចំនេះដឹងបន្ថែមទៀតសំរាប់លោកអ្នក សូមអរគុណសំរាប់ការគាំទ្រ !

1/ Lab OSPF

download document: link download 

download command : Link




R1

#interface loopback 1

ip address 1.1.1.1 255.255.255.255

router ospf 1

router-id 1.1.1.1

network 10.10.10.0 0.0.0.255 area 0

network 10.1.1.0 0.0.0.3 area 0

network 30.3.3.0 0.0.0.3 area 0

network 50.5.5.0 0.0.0.3 area 0

#interface GigabitEthernet 4/0

ip ospf network point-to-point

#interface GigabitEthernet 0/0

ip ospf network point-to-point

#interface GigabitEthernet 1/0

ip ospf network point-to-point

#int g0/0

ip ospf cost 10

=================================================

R2

#interface loopback 2

ip address 2.2.2.2 255.255.255.255

router ospf 1

router-id 2.2.2.2

network 20.20.20.0 0.0.0.255 area 0

network 10.1.1.0 0.0.0.3 area 0

network 20.2.2.0 0.0.0.3 area 0

#interface GigabitEthernet 1/0

ip ospf network point-to-point

#interface GigabitEthernet 2/0

ip ospf network point-to-point

=============================================================================

R3

#interface loopback 3

ip address 3.3.3.3 255.255.255.255

router ospf 1

router-id 3.3.3.3

network 30.30.30.0 0.0.0.255 area 0

network 30.3.3.0 0.0.0.3 area 0

network 40.4.4.0 0.0.0.3 area 0

#interface GigabitEthernet 3/0

ip ospf network point-to-point

#interface GigabitEthernet 4/0

ip ospf network point-to-point


==============================================================================

R4

#interface loopback 4

ip address 4.4.4.4 255.255.255.255

router ospf 1

router-id 4.4.4.4

network 40.40.40.0 0.0.0.255 area 0

network 20.2.2.0 0.0.0.3 area 0

network 40.4.4.0 0.0.0.3 area 0

network 50.5.5.0 0.0.0.3 area 0

#interface GigabitEthernet 2/0

ip ospf network point-to-point

#interface GigabitEthernet 3/0

ip ospf network point-to-point

#interface GigabitEthernet 0/0

ip ospf network point-to-point


#int g0/0

ip ospf cost 10

============================================================================

command :

#interface loopback 0

  ip address 1.1.1.1 255.255.255.255

#sh run int loopback 0 : view IP Lo 0

after change router-id

#clear ip ospf process -> yes : clear ospf process

#sh ip ospf neighbor : show neighbor ospf

#interface g1

#ip ospf cost 10

#sh ip ospf interface brief : view Cost number on interface

#show ip ospf interface GigabitEthernet 0/0/0

#interface GigabitEthernet 0/0/0

ip ospf network point-to-point


====================

command PC on GNS3

#ip 10.10.10.2 255.255.255.0 10.10.10.1 :  IP: 10.10.10.2/24 gateway 10.10.10.1 

#save : save configuration on PC

#sh ip : show IP address on PC



 1/ Configure HA Nexus Switch v1



Guide and Command : 

Configure LAB seen above:
1. Enable vPC feature
  1.1 Configure vPC domain for both Nexus Switch:2
2. Configure vPC Peer-Keep Alive Link(L3) witch would send/receive heart beat messages between both nexus devices.
3. Configure vPC Peer-Link witch will carry the traffic between VPC pears
4. Member ports into vPC 21

NEXUS01

switch#conf t
switch(config)#hostname nexus01
nexus01(config)#feature vpc
nexus01(config)#int ethernet 1/3
nexus01(config-if)#no switchport
nexus01(config-if)#no shutdown
nexus01(config-if)#ip address 1.1.1.1/24
nexus01(config-if)#exit
nexus01(config)#ping 1.1.1.2
nexus01(config)#vpc domain 2
nexus01(config-vpc-domain)#peer-keepalive destination 1.1.1.2 source 1.1.1.1 vrf defult
nexus01(config-vpc-domain)#exit
nexus01(config)#show vpc brief
nexus01(config)#interface ethernet 1/2, ethernet 1/1
nexus01(config-if-range)#no shutdown
nexus01(config-if-range)#switchport
nexus01(config-if-range)#channel-group 1
nexus01(config-if-range)#exit
nexus01(config)#interface port-channel 1
nexus01(config-if)#switchport
nexus01(config-if)#switchport mode trunk
nexus01(config-if)#switchport trunk allow vlan all
nexus01(config-if)#vpc peer-link
nexus01(config-if)#exit
nexus01(config)#interface ethernet 1/4, ethernet 1/5
nexus01(config-if-range)#switchport
nexus01(config-if-range)#channel-group 2
nexus01(config-if-range)#no shutdown
nexus01(config-if-range)#exit
nexus01(config)#interface po2
nexus01(config-if)#switchport mode trunk
nexus01(config-if)#vpc 21
nexus01(config-if)#exit
nexus01(config)#copy running-config startup-config
nexus01(config)#show vpc brief


========================================================================
NEXUS02

switch#conf t
switch(config)#hostname nexus02
nexus02(config)#feature vpc
nexus02(config)#int ethernet 1/3
nexus02(config-if)# no switchport
nexus02(config-if)#no shutdown
nexus02(config-if)#ip address 1.1.1.2/24
nexus02(config-if)#exit
switch(config)#vpc domain 2
nexus02(config-vpc-domain)#peer-keepalive destination 1.1.1.1 source 1.1.1.2 vrf default
nexus02(config-vpc-domain)# exit
nexus02(config)#show vpc brief
nexus02(config)#interface ethernet 1/1, ethernet 1/2
nexus02(config-if-range)#no shutdown
nexus02(config-if-range)#switchport
nexus02(config-if-range)#channel-group 1
nexus02(config-if-range)#exit
nexus02(config)#interface port-channel 1
nexus02(config-if)#switchport
nexus02(config-if)#switchport mode trunk
nexus02(config-if)#switchport trunk allow vlan all
nexus02(config-if)#vpc peer-link
nexus02(config-if)#exit
nexus02(config)#interface ethernet 1/4, ethernet 1/5
nexus02(config-if-range)#switchport
nexus02(config-if-range)#channel-group 2
nexus02(config-if-range)#no shutdown
nexus02(config-if-range)#exit
nexus02(config)# interface po2
nexus02(config-if)#switchport mode trunk
nexus02(config-if)#vpc 21
nexus02(config-if)#exit
nexus02(config)# copy running-config startup-config

=========================================================================
#Switch>en
Switch#conf t
Switch(config)#hostname SW1
SW1(config)#interface port-channel2
SW1(config-if)#switchport
SW1(config-if)# switchport trunk encapsulation dot1q
SW1(config-if)# switchport mode trunk
SW1(config-if)# no shutdown
SW1(config-if)#exit
SW1(config)#interface range gigabit0/0-3
SW1(config-if-range)# switchport trunk encapsulation dot1q
SW1(config-if-range)# channel-group 2 mode on
SW1(config-if-range)# no shutdown
SW1(config-if-range)#exit
SW1(config)#exit
SW1#copy running-config startup-config


Backup IOS And Configuration Router

Backup IOS And Configuration Router
   1/ Backup IOS:


Backup IOS Router : video
Backuo IOS Router : file
 
   2/ Backup Configuration:


Backup Configuration Router : video
Backup Configuration Router : file

2 : Configure and manage resource pools




Each standalone host and each DRS cluster has an (invisible) root resource pool that groups the resources of that host or cluster. The root resource pool is not displayed because the resources of the host (or cluster) and the root resource pool are always the same.
Users can create child resource pools of the root resource pool or of any user-created child resource pool. Each child resource pool owns some of the parent’s resources and can, in turn, have a hierarchy of child resource pools to represent successively smaller units of computational capability.
A resource pool can contain child resource pools, virtual machines, or both. You can create a hierarchy of shared resources. The resource pools at a higher level are called parent resource pools. Resource pools and virtual machines that are at the same level are called siblings. The cluster itself represents the root resource pool.
In Figure 3-1, RP-QA is the parent resource pool for RP-QA-UI. RP-Marketing and RP-QA are siblings. The three virtual machines immediately below RP-Marketing are also siblings.
For each resource pool, specify reservation, limit, shares, and whether the reservation should be expandable. The resource pool resources are then available to child resource pools and virtual machines.

You can use resource allocation settings to manage a resource pool.

Resource Pool Attributes is a summary of the attributes that you can specify for a resource pool.